Applies to
Canon Pixma MP258 (Possible all MP250 series)  Photo All-In-One Printer



Requirements
Windows 8.1/8.1 x64/8/8 x64/7/7 x64/Vista/Vista64/XP , USB 2.0 connection

Author
Canon.com

FileName
mp68-win-mp250-1_05-ea24.exe

FileSize
20.09 MB

Driver Date & Version
02/01/2014 (ver. 1.05)

Description

The driver mentioned here is for model MP250. MP258 probably is a region-specific model so I think the driver for MP250 will work as well. The driver is for the latest Windows 8.1 all the way down to XP (Windows 8.1/8.1 x64/8/8 x64/7/7 x64/Vista/Vista64/XP). You will also need a high-speed USB 2.0 connection but I think a slower USB1.1 will work too, maybe slower.

As always, make a backup of your important files because installing this driver.

  1. [Ver.1.05]: Windows 8 and 8.1 has been added as a supported OS.
  2. [Ver.1.04]: The following problem has been rectified: When cancelling the print job in collated printing multiple numbers of copies, the print job may not be deleted.
  3. [Ver.1.03]: The problem that scanning cannot be performed properly in some of the application software has been rectified.
  4. [Ver.1.02]: Officially supports Windows 7.

You should install the latest version of MP258 driver if you are upgrading from Windows 8 to 8.1 as the driver fixes two major bugs:

  1. If the printer driver is installed in Windows 8, and if Windows 8 is upgraded to Windows 8.1 while keeping the printer driver installed, Enable bidirectional support in the printer properties may be deselected, disabling detection of the ink level, etc. Re-install the printer driver after upgrading to Windows 8.1 and Enable bidirectional support is selected.
  2. If the scanner driver is installed in Windows 8, and if Windows 8 is upgraded to Windows 8.1 while keeping the scanner driver installed, scanning from the product (by using the SCAN button) may not be available. Re-install the scanner driver after upgrading to Windows 8.1.

Download Canon Pixma MP258 Driver here.

Leave a Reply

Your email address will not be published. Required fields are marked *